Modello di fattura a più aliquote IVA

di Corrado Del Buono

scritto il

Realizzare un foglio per calcolare fatture prevedendo sconti, applicazione di diverse aliquote IVA e spese non documentate.

Creare un prospetto fattura è un esercizio abituale per coloro che iniziano ad utilizzare Microsoft Excel: tale prospetto, infatti, racchiude al suo interno alcuni semplici calcoli (moltiplicazioni, percentuali, ..) e funzioni (SOMMA, ARROTONDA, etc.) ed è uno strumento che si rivela utile anche per applicare in concreto alcune regole di formattazione quali, ad esempio, l’unione di più celle, l’assegnazione del formato percentuale o dello stile valuta, ed altro ancora.Diversamente, se intendiamo realizzare un modello di fattura, ovvero un prospetto nel quale si dovranno inserire soltanto i dati strettamente necessari (evitando di inserire ogni volta anche le formule) e se tale modello deve prendere in considerazione la possibilità di un’azienda di fatturare anche prodotti con diverse aliquote IVA, dobbiamo ragionare in termini più complessi introducendo alcune formule che ci consentano ad esempio di ripartire le spese non documentate su “Imponibili soggetti ad IVA differente” e funzioni logiche come SE e SOMMA.SE. Il modello proposto consente, dopo l’inserimento dei dati variabili (relativi al cliente, ai prodotti venduti, allo sconto sul prezzo di listino e alle spese accessorie, documentate e non documentate), la compilazione automatica della fattura indipendentemente dal fatto che vengano venduti prodotti ad una sola aliquota IVA o a più (scarica il modello).

Come costruire il modello

Il modello, che è stato costruito a partire dalla riga 10 in maniera tale da consentire l’inserimento dei dati anagrafici dell’azienda, può essere idealmente suddiviso in tre parti. La prima parte è relativa ai dati informativi che si inseriscono in fattura: numero e data della fattura e dell’ordine ad essa associato, modalità di pagamento (ad esempio, RI.BA 30gg, Bonifico), banca d’appoggio per la riscossione della fattura, dati relativi al cliente (Nome, Codice Fiscale/Partita IVA).

Figura 1. Dati comuni

Dati comuni

La seconda sezione è relativa alla parte tabellare della fattura, nella quale dovranno essere inseriti i prodotti, i quantitativi venuti, il prezzo unitario, l’eventuale sconto (in formato percentuale) e l’aliquota IVA relativa al prodotto.

Figura 2. Tabella dei prodotti

Tabella dei prodotti

La colonna F della parte tabellare contiene le prime formule del modello fattura.
Nella cella F18 è stata inserita la formula:

  • =ARROTONDA(B18*C18*(1-D18);2)

Attraverso tale formula chiediamo ad Excel di arrotondare a due cifre decimali il valore che scaturisce dalla moltiplicazione delle quantità (B18) per il prezzo unitario (C18) al netto della percentuale di sconto eventualmente contenuta nella cella D18 (1-D18). Facciamo un esempio per chiarire quest’ultima parte della formula: uno sconto del 5% corrisponde, matematicamente, al valore 0,05 e, pertanto, moltiplicando le quantità per il prezzo unitario per 0,95 (1-0,05) si ottiene l’importo al netto dello sconto. La formula poteva essere scritta senza “semplificazioni”, ovvero calcolando prima il valore complessivo (B18*C18) e successivamente sottraendo da quest’ultimo lo sconto (B18*C18*D18), nel modo seguente:

  • =ARROTONDA(B18*C18-B18*C18*D18;2)

La formula è stata successivamente copiata verso il basso fino alla cella F27, mentre nella cella F28 è stata inserita la funzione

  • =SOMMA(F18:F27).

Analizziamo la terza sezione del modello, quella che spero apporti “valore aggiunto” alle conoscenze del lettore.

Figura 3. Tabella finale

Tabella finale

La normativa fiscale prevede che le “spese non documentate” (spese di trasporto, di imballo, etc. non fatturate in precedenza) debbano essere ripartite tra i diversi imponibili soggetti ad aliquote differenti (al netto di eventuali sconti). Nell’intervallo A30:F33 del modello fattura, pertanto, sono stati inseriti i calcoli per effettuare tale riparto nel rispetto della normativa. La cella A31 dovrà contenere le spese non documentate o accessorie, mentre nell’intervallo C31:C33 sono state inserite le tre diverse aliquote IVA vigenti nel nostro sistema tributario. L’intervallo B31:B33 “raggruppa” per aliquota IVA i valori contenuti nella colonna F della sezione due del modello (Importi scontati) attraverso la funzione SOMMA.SE.

La funzione, appartenente alla categoria “Matematiche e trigonometriche” ha la seguente sintassi:

  • =SOMMA.SE(intervallo;criteri;int_somma)

e può essere riassunta nel seguente modo: Excel somma tutte le celle facente parti dell’intervallo “int_somma” (terzo argomento della funzione) quando le celle contenute nell’intervallo di riferimento (primo argomento della funzione) soddisfano i criteri assegnati (secondo argomento della funzione). Ad esempio la funzione

  • =SOMMA.SE(A1:A10;”<6″;B1:B10)

ordina ad Excel di sommare tutte le celle contenute nell’intervallo B1:B10 se le rispettive celle dell’intervallo A1:A10 hanno un valore minore di 6. Torniamo al nostro modello. In B31 è stata inserita la funzione:

  • =SOMMA.SE($E$18:$E$27;C31;$F$18:$F$27)

La funzione SOMMA.SE chiede ad Excel di sommare tutti gli importi contenuti nella colonna “Importi scontati” (terzo argomento della funzione, $F$18:$F$27) soltanto se le rispettive celle della colonna “Aliquota IVA” (primo argomento della funzione, $E$18:$E$27) contengono il valore esemplificativo 20% (secondo argomento della funzione, C31). La funzione, costruita con i riferimenti assoluti, è stata successivamente copiata nelle due celle sottostanti. Nella colonna D si è proceduto ad assegnare parte delle spese non documentate attraverso la formula del riparto utilizzando per la sua costruzione la funzione SE. Più in dettaglio, nella cella E31 è stata trascritta la formula:

  • =SE($A$31=””;0;$A$31/$F$28*B31)

Con questa formula si chiede ad Excel di verificare che la cella A31 sia vuota e di restituire, nel caso in cui il test è vero, il valore zero (0), altrimenti, di restituire il valore che scaturisce dalla divisione tra le spese non documentate (A31) e il totale della colonna “Importo scontato” (F28) (questa divisione viene chiamata comunemente “coefficiente di riparto”) moltiplicato per l’Imponibile lordo soggetto ad aliquota IVA ad esempio al 20% (B31). La funzione, alla quale sono stati assegnati dei riferimenti assoluti, è stata successivamente copiata nelle due celle sottostanti.

Da notare che l’inserimento del calcolo del riparto all’interno della funzione SE non è strettamente necessario ma serve ad evitare che, a modello vuoto, compaia il messaggio di errore #DIV/0! nelle celle che contengono le formule del riparto. Infine, l’imponibile netto è stato calcolato per differenza tra l’Imponibile lordo e le spese ripartite (in E31 è stata inserita la formula =B31-D31 e successivamente è stata copiata verso il basso), l’IVA è stata calcolata moltiplicando il valore dell’Imponibile netto per l’aliquota IVA (in F31 è stata inserita la formula =E31*C31), l’Imponibile totale (E36) e l’IMPOSTA (F36) sono state calcolate sommando rispettivamente gli intervalli E31:E33 e F31:F33) mentre il totale fattura (cella C41) è stato calcolato sommando l’Imponibile totale, l’IMPOSTA e le spese non soggette ad IVA (che andranno inserite nelle celle C38 e C39).

Personalizzare il modello

Nella prima parte della fattura possono essere aggiunte ulteriori informazioni non presenti nel modello: ad esempio, se si vende generalmente con fattura differita, può essere utile indicare anche il numero e la data del documento di trasporto (DDT). Con riferimento alla seconda parte della fattura possiamo creare organizzare il listino prezzi dell’azienda in un ulteriore foglio di calcolo e richiamare i suoi dati all’interno della parte tabellare della fattura attraverso l’utilizzo della funzione CERCA.VERT. Ulteriori informazioni, quali ad esempio il calcolo di interessi per fatture con pagamento dilazionato, possono essere aggiunte, infine, nella terza parte del modello.

I Video di PMI

Aumento IVA: la clausola di salvaguardia