Tassi di cambio: convertire valute in tempo reale con Excel

di Gianluca Tinti

scritto il

Come collegare Excel ad una pagina web per aggiornare i tassi di cambio in tempo reale e su questi eseguire eventuali operazioni di conversione.

Con questo tutorial ci proponiamo di utilizzare Microsoft Excel per costruire un convertitore di valuta in cui i valori relativi ai vari tassi di cambio risultino sempre aggiornati in tempo reale tramite Internet, a cui il foglio di calcolo verrà collegato.

Vi proponiamo sia l’esempio completo (pronto per il download) sia l’esempio che riporta i fogli di lavoro già pronti all’uso.

Per creare da sé il convertitore di valuta, per prima cosa apriamo una nuova cartella di lavoro e rinominiamo il foglio 1 come Tasso e il foglio 2 come Cambio.

Posizioniamoci sul foglio Cambio e riproduciamo le tabelle riprodotte in basso, ognuno potrà scegliere di formattare le celle a proprio piacimento:

=> Convertitore di valuta: scarica esempio completo

 

Ora andiamo su Internet e scegliamo un sito che riporti i tassi di cambio delle valute in riferimento all’euro, come ad esempio Exchange-rates.org. La schermata che il vostro PC dovrebbe visualizzare è simile a questa:

Il passo successivo consiste nell’importare la tabella dati presente nel sito all’interno del nostro file. A tale scopo ci posizioniamo sul foglio Tasso della nostra cartella di lavoro, e visualizziamo la barra multifunzione Dati:

 

All’inizio della barra multifunzione Dati, troviamo la sezione di pulsanti “Carica dati esterni“.

Clicchiamo il pulsante Da Web per iniziare la procedura di collegamento al sito internet.
Il nostro PC a questo punto dovrebbe mostrare la finestra “Nuova Query Web”.

All’interno, nella parte superiore, troveremo il campo in cui inserire l’indirizzo della pagina web da collegare: scriviamolo e poi clicchiamo il pulsante Vai.

Nella pagina che si è scelto di visualizzare sono mostrati dei tag di posizionamento rappresentati da piccole frecce nere su sfondo giallo. Tali tag individuano le possibili tabelle presenti nella pagina stessa.

Per selezionare una tabella ai fini dell’importazione basta cliccare sul relativo tag, a questo punto comparirà al posto della freccetta una spunta nera su sfondo verde, che ci indicherà quali dati della pagina verranno importati su Excel. Noi cliccheremo sul tag relativo alla tabella contenente i tassi di cambio:

A questo punto siamo pronti per trasferire i dati:

    1. Facciamo click sul pulsante Importa
    2. Compare la finestra Importa dati:

  1. Lasciamo selezionata l’opzione “Nel foglio di lavoro esistente” e lasciamo la cella =$a$1 nell’apposito spazio (è da qui che verranno trascritti i dati nel foglio di lavoro)
  2. Click su OK
  3. Compaiono i dati importati:

Vediamo ora come  nascondere i dati che non servono.

Nascondere i dati che non servono

Ovviamente verranno importati tutti i dati presenti nella tabella selezionata all’interno della pagina web, compresi quelli che a noi non servono. Per esempio, i dati della colonna A sicuramente non tornano utili alla nostra causa, così come quelli delle colonne E ed F.

In linea teorica potremmo cancellarli (ci è consentito), solo che ad ogni aggiornamento dati successivo verranno ricaricati e ritrascritti. Per evitare ogni volta di ripetere la stessa operazione di cancellazione è possibile, anziché eliminare, nascondere le colonne che non servono. A questo scopo eseguiamo i punti seguenti:

  1. Selezioniamo la colonna A
  2. Clicchiamoci sopra col tasto destro
  3. Clicchiamo su Nascondi
  4. Ripetiamo l’operazione sulla colonna E ed F

Aggiornamento dati

Ora siamo pronti per aggiornare i dati tutte le volte che ne abbiamo necessità, questa operazione potrà essere eseguita manualmente o automaticamente. Se abbiamo bisogno di un aggiornamento immediato è sufficiente fare click sul pulsante Aggiorna tutti della barra multifunzione Dati, dopo qualche secondo verrà eseguita l’operazione.

È possibile far aggiornare i dati automaticamente dal programma ad intervalli di tempo regolari, ovviamente per poter eseguire questa operazione occorrerà lasciare aperto il file di Excel. Per l’aggiornamento automatico occorre:

  1. fare click sul pulsante Proprietà all’interno della barra multifunzione Dati;
  2. dalla finestra “Proprietà intervallo dati esterno”  scegliere per esempio di eseguire l’aggiornamento in Background, o ad intervalli di tempo regolari e/o all’apertura del file.
  3. dopo avere operato le scelte facciamo click su OK.

Impostare le operazioni di conversione valuta

Una volta visto come collegarsi alla pagina web e come aggiornare i dati sul nostro foglio elettronico, andiamo a costruire il nostro convertitore di valuta impostando le funzioni matematiche necessarie.

Prima però due precisazioni:

  • Nel foglio Cambio creato all’inizio, alle celle B4 e A7 abbiamo associato un colore di sfondo Nero: poiché in seguito andremo a scrivere su queste celle, fate in modo di avere un colore carattere diverso dal nero (noi, nel nostro esempio, abbiamo scelto il rosso).
  • Per comodità l’intervallo di celle B4:E4 (sempre nel foglio Cambio del nostro esempio) è stato unito. Per unire delle celle occorre semplicemente selezionarle e poi fare click sul pulsante Unisci e centra nella barra Home.

Ora siamo pronti e possiamo come prima operazione posizionarci sulla cella A2 del foglio Cambio. Qui creeremo un menù a tendina che ci consentirà di scegliere una valuta tra tutte quelle presenti nel foglio Tassi, che utilizzeremo per la conversione in €uro (o viceversa). A tale scopo eseguiamo le seguenti operazioni:

  1. cliccare il pulsante Convalida dati presente nella barra multifunzione Dati;
  2. nella finestra convalida dati cliccare sulla voce elenco presente nel menù Seleziona e scrivere all’interno del campo Origine: “=Tasso!B2:B30”;
  3. Al termine cliccare su OK.

Se ora proviamo a posizionarci su A2 avremo la possibilità di aprire il menù contenente tutti i nomi delle valute importate in precedenza nel foglio Tasso.

Realizzando la procedura seguente invece faremo in modo che oltre al nome della valuta compaia il relativo tasso di cambio e la data di aggiornamento:

  1. Posizioniamoci nella cella B2 del foglio Cambio e scriviamo la seguente formula:
    =SE(A2=0;””;(CERCA.VERT(A2;Tasso!B2:F1000;2;FALSO)))
  2. Posizioniamoci nella cella D2 e scriviamo la seguente formula:
    =SE(A2=0;””;(CERCA.VERT(A2;Tasso!B2:F1000;3;FALSO)))

Se tutto è stato fatto correttamente basterà selezionare una voce nel menù della cella A2 e vi accorgerete che in automatico verranno riportati, nelle celle B2 e D2, i valori corrispondenti.

Come convertire da euro ad altra valuta

Attraverso l’esecuzione della seguente procedura, proveremo a convertire una qualsiasi cifra, espressa in €uro, in altra valuta. A tale scopo posizioniamoci sulla cella B5 del foglio Cambio e scriviamo la seguente formula: =SE(A5=””;””;B2*A5)

Proviamo ora a selezionare una valuta attraverso il menù della cella A2, poi posizioniamoci nella cella A5 e scriviamo l’ammontare degli €uro da convertire nella valuta selezionata. Se abbiamo fatto tutto correttamente, nella cella B5 dovrebbe essere eseguita la conversione.

Perché il tutto sia più facilmente leggibile possiamo scrivere nella cella B4 la seguente formula: =SE(A2=””;””;A2)
In questo modo verrà riportato nella stessa mini-tabella la valuta selezionata.

Come convertire in euro un valore espresso in diversa valuta

Attraverso l’esecuzione della seguente procedura, proveremo a convertire una qualsiasi cifra in €uro. A tale scopo:
Posizioniamoci sulla cella B8 del foglio Cambio e scriviamo la seguente formula: =SE(A8=””;””;A8/B2)

Proviamo ora a selezionare una valuta attraverso il menù della cella A2, poi posizioniamoci nella cella A8 e scriviamo la cifra da convertire in €uro. Se abbiamo fatto tutto correttamente, nella cella B8 dovrebbe essere eseguita la conversione.
Perché il tutto sia più facilmente leggibile possiamo scrivere nella cella A7 la seguente formula: =SE(A2=””;””;A2)
In questo modo verrà riportato nella stessa mini-tabella la valuta selezionata.