Calcolo della “scadenza adeguata” con EXCEL

di Corrado Del Buono

scritto il

Quando due imprese sussistono rapporti di affari che generano continui rapporti di credito/debito, si cerca di effettuare i pagamenti in un'unica soluzione.

La “scadenza adeguata” è pratica aziendale che consente di stabilire il giorno nel quale deve essere versato il saldo per evitare che uno dei due soggetti economici subisca ripercussioni finanziarie negative (da cui nasce appunto il termine “adeguata”). Facciamo un esempio per illustrare meglio il concetto finanziario che è alla base di questa pratica aziendale. Supponiamo che l’impresa A debba pagare una dozzina di fatture all’impresa B scadenti nel periodo settembre-novembre; è possibile unificare i pagamenti in maniera tale da fare una sola transazione finanziaria e quindi evitare i “disagi” che queste ultime comportano non solo in termini di spesa (si pensi, ad esempio, alle commissioni bancarie necessarie per ogni operazione) ma anche in termini di tempi (si pensi, ad esempio, alle operazioni di contabilizzazione che i rispettivi uffici amministrativi devono compiere).

=> La “scadenza comune stabilita” con EXCEL

Il problema da “risolvere” può essere riassunto da questa domanda: quale è il giorno nel quale deve essere effettuato il pagamento per non danneggiare né l’impresa A né l’impresa B? Intuitivamente, è sicuramente un giorno intermedio tra la scadenza del primo documento e la scadenza dell’ultimo documento: in questo modo, l’impresa debitrice (l’impresa A) posticipa il pagamento di alcuni debiti avendo un ritorno positivo in termini finanziari (dovendo scegliere di pagare una stessa somma oggi o in futuro, è sicuramente più vantaggioso pagarla in futuro perché, almeno in linea teorica, è possibile reinvestire il capitale e ottenere, nel frattempo, un rendimento) e anticipa il pagamento di altri debiti che sarebbero scaduti successivamente avendo un ritorno negativo in termini finanziari.

=> Scarica il modello

Simmetricamente, per l’impresa creditrice (impresa B) avviene esattamente l’opposto (concedere dilazioni di pagamento è finanziariamente negativo mentre ottenere la disponibilità di un credito in anticipo è finanziariamente positivo). Matematicamente, il calcolo della “scadenza adeguata” è una “media aritmetica ponderata” che tiene in considerazione sia l’entità degli importi dei singoli documenti, sia le date di scadenza: dal punto di vista finanziario, ciò implica che è indifferente pagare ognuno dei singoli debiti alla scadenza naturale oppure pagare la somma di tutti i debiti alla data della scadenza adeguata. Il modello proposto in questo tutorial consente, dopo l’inserimento degli importi e delle scadenze dei singoli documenti, di determinare la data equa, la “scadenza adeguata” appunto, nella quale effettuare il pagamento unificato.

 

Come costruire il modello proposto

Vediamo nel dettaglio come si usa e come è stato costruito il modello. Nell’intervallo A4:C13 si inseriscono fino a dieci documenti attestanti il debito (principalmente, fatture), il loro importo e la loro scadenza. I “debiti” devono essere inseriti con le scadenze in ordine crescente, ovvero dal documento che scade prima a quello che scade per ultimo. Nelle celle della colonna D vengono indicati i giorni che intercorrono tra la prima scadenza (che in ambito aziendale viene definita “epoca”) e le rispettive scadenze dei documenti successivi al primo. Più in dettaglio, nella cella D5 è stata inserita la seguente formula:

=SE(C5=””;0;C5-$C$4)

che può essere letta in questo modo: se non è indicata alcuna scadenza nella cella a sinistra (C5) inserisci uno zero (0) altrimenti calcola la differenza tra la data contenuta nella cella C5 e la data dell’epoca contenuta nella cella C4.

Per impostazione predefinita, generalmente, quando si esegue una differenza tra due date, Excel restituisce il risultato sempre in formato data; per trasformarlo in formato numerico occorre, dopo l’inserimento della formula, formattare la cella con un formato numerico: per farlo è sufficiente selezionare la cella, utilizzare il comando Celle disponibile all’interno del menu FORMATO e, nella scheda Numero della finestra “Formato celle” che appare a video, selezionare Generale dall’elenco Categoria (in alternativa, si può utilizzare il formato Valuta con 0 cifre decimali). Il contenuto della cella D5 è stato successivamente copiato verso il basso fino alla cella D13.

I Numeri, ad eccezione di quello in corrispondenza dell’epoca che avrà valore pari a zero (0), si calcolano moltiplicando l’Importo per i Giorni. Pertanto nella cella E5 è stata inserita la formula =B5*D5 e, successivamente è stata copiata sempre fino alla riga 13. La cella B14 contiene la somma dell’intervallo B4:B13, ovvero del totale dei documenti dei quali si preferisce unificare il pagamento. La scadenza adeguata si calcola aggiungendo alla data dell’epoca il risultato della divisione tra il totale Numeri e il totale Importo arrotondato a zero cifre decimali (quest’ultimo risultato è comunemente definito “giorni da aggiungere all’epoca”); pertanto, nella cella B15 è stata utilizzata la formula:

=SE(B14=0;””;C4+ARROTONDA(SOMMA(E5:E13)/B14;0))

Da notare che la funzione ARROTONDA è costituita da un argomento indicante il valore da arrotondare (nel caso specifico la somma della colonna Numeri diviso il totale della colonna Importo) e da un secondo argomento indicante il numero di cifre da utilizzare come arrotondamento (nel caso specifico 0); l’inserimento della formula all’interno della funzione SE, inoltre, consente di visualizzare il risultato soltanto se esiste un valore (diverso da zero) nella cella B14 (in questo modo, se il prospetto non è stato ancora utilizzato si evita la comparsa, nella cella B15, del messaggio di errore #DIV/0!); infine, poiché il risultato deve essere espresso in formato data, non si rende necessario formattare la cella con un formato numerico. Per concludere osserviamo come è possibile personalizzare il modello proposto; quest’ultimo è stato costruito prevedendo 10 inserimenti di documenti: se necessitano ulteriori righe è sufficiente inserirle all’interno del prospetto (in una riga compresa tra la sesta e la dodicesima) e ricopiare nuovamente verso il basso le formule contenute nelle celle D5 e E5.