Scadenza comune stabilita per debiti e fatture

di Corrado Del Buono

scritto il

Calcolare l'importo per estinguere un finanziamento partendo da un tasso di interesse e una data stabilita tra le parti.

La “scadenza comune stabilita” è un accordo tra due imprese per regolare, in un’unica soluzione e ad una scadenza concordata, i rapporti di credito/debito derivanti da fatture o altri documenti contabili; il tasso di interesse, che viene stabilito tra le parti, è normalmente quello praticato dalle aziende di credito per la concessione di prestiti a breve termine. Questa soluzione è praticata, generalmente, quando ci sono molti rapporti di affari e ognuno prevede l’introito o l’esborso di somme di denaro non eccessive (ad esempio, ai rapporti di affari tra un grossista e un piccolo negozio di generi alimentari).

=> Scarica il modello

Il modello proposto in questo tutorial consente di determinare tale importo tenendo conto di tutte le variabili indicate: importi e data di scadenza delle singole fatture, scadenza comune stabilita, tasso di interesse concordato.

Facciamo un esempio per illustrare meglio il concetto finanziario che è alla base di questa pratica aziendale. Supponiamo che l’impresa A debba pagare cinque fatture all’impresa B scadenti tra il mese di luglio e settembre; per evitare di fare cinque transazioni finanziarie (e quindi per evitare spese in commissioni bancarie o accessorie e sprechi di tempi per la contabilizzazione delle operazioni), le due imprese possono accordarsi stabilendo che l’impresa B paghi i suoi debiti in un’unica soluzione e ad una scadenza stabilita (ad esempio, il 20 di agosto).

L’importo dovuto viene calcolato sommando il totale degli importi delle singole fatture al netto di uno sconto per le fatture la cui scadenza è successiva a quella stabilita e con l’aggiunta di interessi per le fatture scadute prima del 20 di agosto (lo sconto e gli interessi vengono calcolati applicando un tasso unico concordato tra le parti).

=> Calcolo della “scadenza adeguata” con EXCEL

Costruire il modello proposto

Vediamo nel dettaglio come è stato costruito il modello cominciando ad analizzare le celle di input.

Figura 1. Schermata del modello

Schermata del modello

Nella cella B3 dovrà essere inserita la data stabilita per il pagamento unificato mentre nella cella B4 dovrà essere indicato il tasso di interesse da praticare in formato percentuale. L’intervallo A6:C15 consente l’inserimento di dieci documenti attestanti il debito (principalmente, fatture), il loro importo e la scadenza.

=> Modello sollecito pagamento fatture: la guida

Tutte le altre celle del modello contengono formule. Esaminiamole.Nella colonna D dovranno apparire i giorni che intercorrono tra la scadenza della fattura e la data concordata per il pagamento unificato (si chiamano comunemente “Giorni di anticipo” poiché la fattura viene pagata anticipatamente rispetto alla sua scadenza naturale); diversamente, nella colonna E dovranno apparire i giorni che intercorrono tra la data della scadenza concordata e quella della scadenza del documento (si chiamano “Giorni di ritardo” perché la fattura doveva già essere pagata ma, per gli accordi intrapresi, verrà saldata solo alla data della scadenza comune stabilita).

In D6, pertanto, è stata utilizzata la funzione SE nidificata e coadiuvata dall’operatore logico O.

=SE(O($B$3=””;C6=””);0;SE((C6-$B$3)>0;C6-$B$3;0))

La funzione può essere letta in questo modo: «Se la cella contenente la scadenza concordata (B3) oppure la cella relativa alla data di scadenza del documento (C6) è vuota, restituisci uno zero (0), altrimenti se la differenza tra la scadenza della fattura (C6) e la scadenza concordata (B3) è positiva (ovvero se la fattura ha una scadenza successiva rispetto a quella concordata per il pagamento) restituisci tale valore (giorni di anticipo), altrimenti (e quindi, nel caso in cui la scadenza della fattura è anteriore alla data della scadenza concordata) restituisci uno zero (0)».

In questo modo, vedremo comparire dei numeri nella colonna D soltanto se le scadenze delle fatture sono posticipate rispetto alla scadenza concordata.

In E6 è stata utilizzata una funzione simile che consente di visualizzare il numero dei giorni soltanto se la scadenza della fattura è anteriore a quella concordata.

=SE(O($B$3=””;C6=””);0;SE(($B$3-C6)>0;$B$3-C6;0))

I “Numeri di sconto” si calcolano moltiplicando i giorni di anticipo per l’importo del documento; pertanto, in F6 è stata utilizzata la seguente funzione:

=SE(D6=0;0;B6*D6)

che può essere letta in questo modo:

«se i giorni di anticipo (contenuti nella cella D6) sono pari a zero (0) scrivi zero, altrimenti moltiplica tali giorni per l’importo del documento (B6*D6)».

Per calcolare i “Numeri di interesse” (= giorni di ritardo * importo) è stata utilizzata in E6 una funzione simile a quella appena analizzata.

=SE(E6=0;0;E6*B6))

Da notare che in queste formule è stata utilizzata la funzione SE in maniera simmetrica: questo accorgimento consente, dopo l’inserimento della data di scadenza del documento nella cella C6, di avere dei valori o nelle celle D6 e F6 (se la data è posteriore a quella della scadenza concordata) o nelle celle E6 e G6 (se la data è anteriore).

Le quattro funzioni sono state costruite con riferimenti assoluti (quando necessari) per essere ricopiate verso il basso (fino alla riga 15) con il semplice trascinamento del quadratino di riempimento.

La cella B16 contiene il totale della colonna Importo mentre la cella B17 contiene la formula per il calcolo contestuale dello Sconto o dell’Interesse. La formula utilizzata è:

=(SOMMA(G6:G15)-SOMMA(F6:F15))*B4/365

Moltiplica la differenza tra la somma dei Numeri di interesse e quella dei Numeri di sconto per il tasso concordato (B4) e divide il risultato per 365 (i giorni dell’anno civile); così costruita, la formula restituisce un risultato negativo (<0) in caso di sconto e positivo (>0) in caso di interesse: pertanto, l’importo a saldo, inserito della cella sottostante (B18), è stato calcolato semplicemente sommando la cella B16 con la cella B17 (=B16+B17).

Inoltre, poiché il risultato della formula contenuta in B17 dipende dai dati utilizzati nel prospetto, è stata utilizzata una formula anche nella cella A17 che consente di visualizzare l’etichetta “SCONTO” o “INTERESSE” a seconda dei casi.

La formula utilizzata, che per comodità fa riferimento al risultato della cella B17 (e non al totale dei Numeri di sconto e di interesse), è la seguente:

=SE(B17=0;””;SE(B17>0;”INTERESSE”;”SCONTO”))

E può essere letta in questo modo:

«se il valore della cella B17 è pari a zero (0) restituisci un’etichetta vuota (le doppie virgolette “”), altrimenti se tale valore è positivo (B17>0) restituisci l’etichetta “INTERESSE”, altrimenti (ovvero, se il valore della cella B17 è negativo) restituisci l’etichetta “SCONTO”».

Solo per completezza di esposizione, se si consideravano i dati di origine (Numeri di interesse e di sconto) si doveva creare la seguente formula:

=SE(SOMMA(G6:G15)=SOMMA(F6:F15);””;SE(SOMMA(G6:G15)>SOMMA(F6:F15);”INTERESSE”;”SCONTO”))

Lasciamo al lettore il compito di analizzarne il contenuto, mentre vediamo, per concludere, come personalizzare il modello; quest’ultimo è stato costruito prevedendo 10 inserimenti di documenti: se necessitano ulteriori righe è sufficiente inserirle all’interno del prospetto (in una riga compresa tra la sesta e la quindicesima) e ricopiare nuovamente verso il basso le formule contenute nella riga 6.

I Video di PMI

Posta elettronica certificata e firma digitale