Arrotondare i numeri decimali in Excel

di Gianfranco Budano

scritto il

La varietà di funzioni standard offerta da Excel è abbastanza variegata e sufficiente a soddisfare le esigenza più disparate, prova ne è la numerosità di funzioni disponibili per l’arrotondamento dei numeri decimali che sono ben sei.

Analizziamo oggi la modalità di arrotondamento più usata, la funzione ARROTONDA, riservandoci di analizzare in futuro le altre.

La funzione ARROTONDA richiede, oltre alla cella da considerare per l’arrotondamento, il numero di cifre che si desidera mantenere dopo la virgola. Se inseriamo zero significa che desideriamo arrotondare all’intero più vicino, se inseriamo un numero decimale significherà che intendiamo arrotondare di tante cifre quante ne abbiamo specificate a sinistra della virgola.

Supponiamo di voler arrotondare il valore della cella B2 che è uguale a 19,4938. Se scriviamo
=ARROTONDA(B2;1)

il risultato sarà uguale a 19,5 poiché abbiamo chiesto di arrotondare il nostro numero di un decimale dopo la virgola.

Se invece scriviamo
=ARROTONDA(B2;0)

il risultato sarà uguale a 19 poiché abbiamo specificato di desiderare zero decimali.

Se infine scriviamo
=ARROTONDA(B2;-1)

il risultato sarà uguale a 20 perché inserendo un numero negativo abbiamo chiesto al sistema di arrotondare a sinistra della virgola.

Come al solito il consiglio è di sperimentare, aiuta la comprensione.