La funzione CONTA.PIU’.SE in Microsoft Excel

di Agnese Bascià

scritto il

Dire che un dato valore ricorre n volte equivale a dire che n celle contengono lo stesso valore: è questo l’assunto di base per ottenere il medesimo risultato da due formule differenti con Microsoft Excel.

Supponiamo di avere una sequenza di celle “A1:A7” contenenti i seguenti valori: 4; 2; 2; 5; 6; 6; 6; volendo conoscere quante volte si ripetono alcuni numeri possiamo impostare la seguente formula posizionandoci nella cella B1:

=CONTA.PIÙ.SE(A1:A7;"=6")

questa restituirà quante volte si ripete il numero 6; modificando il 6 in 2 la formula risulterà:

=CONTA.PIÙ.SE(A1:A7;"=2")

e restituirà quante volte si ripete il numero 2.

Lo stesso risultato si ottiene se impostiamo un’altra formula basata sul calcolo delle celle contenenti un determinato dato (che può essere anche non numerico):

=CONTA.SE(A1:A7;6)

che restituirà “3” ovvero il numero di volte che viene ripetuto il numero 6.

Volendo complicare un po’ le cose, possiamo anche aggiungere che la prima funzione è più complessa della seconda, perché è stata pensata per elaborare risultati basati su criteri multipli: ad esempio, si possono contare le celle contenenti un numero maggiore o uguale a 2 e minore di 6.

La formula diventerà:
=CONTA.PIÙ.SE(A1:A7;">=2";A1:A7;")

e darà come risultato “4” avendo incluso l’intero intervallo “A1:A7” e avendo quindi preso i numeri 2, 2, 4, 5 della successione data.