Tratto dallo speciale:

Acquisto merci a prezzo vantaggioso con Excel

di Gianluca Tinti

scritto il

Ecco un modello Excel per calcolare la quantità di merce da acquistare per ottenere il prezzo più vantaggioso, ridimensionando l'ordine per ottimizzare il nostro acquisto da stoccare in magazzino.

Come può un’impresa fronteggiare un aumento di prezzo della merce da acquistare senza spendere più del previsto? Semplice, basta sfruttare l’ultima occasione d’acquisto vantaggiosa optando per un quantitativo superiore all’immediata necessità. Con il seguente modello Excel già compilato è anche possibile calcolare di quanto dovrà essere ridimensionato l’ordine. Una precisazione: il modello è ideale per prodotti non soggetti a deterioramento o scadenza a breve termine, stoccabili in magazzino per lunghi periodi: questo perché, a seconda dell’aumento di prezzo, il programma consiglierà l’acquisto di elevate scorte di materiale.


Scarica l’esempio

Il Modello

L’impresa deve tener conto dei seguenti fattori:

  • Domanda – quantità di prodotto richiesta dai clienti per un determinato periodo: supponiamo che rimanga costante.
  • Dimensione ordine – quantitativo di prodotto da richiedere al fornitore per ogni ordine minimizzando sia i costi di riordino che di mantenimento.
  • Costo unitario.
  • Costi di riordino – dovuto al trasporto/produzione del materiale: di consegna se da ditta esterna, di produzione se prodotto internamente.
  • Costo di mantenimento – per le scorte in magazzino (es.: cella frigorifera).

=> Gestione ordini e scorte di magazzino con Excel

Facciamo un esempio: supponiamo che il prodotto siano bottiglie di vino.

  • La domanda è costante (1.000 bottiglie/mese) per un totale di 12.000 bottiglie l’anno: Scriviamo 12000 nella cella C2.
  • Ciascuna bottiglia costa 16 € che rappresenta il costo unitario: Scriviamo 16 nella cella C3.
  • Il costo di consegna del prodotto è di 40 €: scriviamo 40 nella cella C4.
  • Stimiamo il costo di mantenimento il 30% di quello unitario: scriviamo nella cella C5 =0,3*C3

La quantità di prodotto da ordinare la calcoliamo inserendo nella cella C7 la seguente formula: =ARROTONDA((RADQ((2*C4*C2)/(C5)));). Questa quantità è calcolata in maniera tale da minimizzare i costi di trasporto e di mantenimento. Nel nostro esempio la formula restituisce il valore 447, ovvero il numero delle bottiglie da ordinare.

L’ordine rappresenta ogni quanti giorni la Quantità di prodotto da ordinare (bottiglie di vino) deve essere richiesta per ripristinare il livello del magazzino e poter garantire il soddisfacimento della domanda. Inseriamo nella cella C8 la formula: =ARROTONDA(((C7/C2)*365);). L’acquisto di 447 (cella C7) bottiglie di vino consente di soddisfare la domanda per 14 giorni dopodiché bisognerà provvedere a un nuovo ordine per ripristinare la fornitura.

La Quantità da calcolare per sfruttare l’ultima occasione di acquisto vantaggiosa a un prezzo unitario minore rispetto a quello che verrà applicato successivamente (chiamiamola d’ora in poi per semplicità Q): per questo definiamo due nuovi dati: Nuovo Costo Unitario e Costo di mantenimento (per esempio il costo di mantenimento di 1kg di carne a temperatura idonea può essere quantificato pari a un decimo rispetto il suo costo al kg).
Ipotizzando che il prezzo delle bottiglie di vino aumenti di 1,5 € quindi, salga a 17,5 €. Scriviamo il nuovo costo unitario nella cella F2. Il costo di mantenimento deve essere considerato proporzionale al costo unitario. Ipotizziamo che si mantenga ancora pari al suo 30%. Nella cella F3 scriviamo =0,3*F2. La formula restituisce un valore di oltre 5€.

Per il calcolo della quantità Q è necessaria la conoscenza della Quantità ottima da ordinare dal momento in cui il prodotto assumerà il nuovo costo unitario. Nel foglio Excel predisponiamo il calcolo per la Quantità di prodotto da ordinare nuovo costo. A tale scopo nella cella F4 inseriamo la formula =ARROTONDA((RADQ((2*C4*C2)/(F3)));)La quantità da ordinare col nuovo costo unitario, si è leggermente abbassata a 428 bottiglie (cella F4).
Ovviamente la quantità da ordinare sarà minore rispetto al caso precedente e di conseguenza, per soddisfare la stessa domanda, diminuirà sensibilmente il tempo in cui le scorte vengono vendute. Inseriamo nella cella F5 la formula =ARROTONDA(((F4/C2)*365);).

Siccome la domanda continua a mantenersi costante, con una quantità minima ordinata, il prodotto si esaurisce prima, nella fattispecie in 13 giorni (cella F5).

Abbiamo quindi tutti i dati per poter calcolare la quantità Q: inseriamo nella cella F7 la formula:=ARROTONDA(((((F2-C3)*C2)/F3))+(F5*(RADQ(F2/C3)));).

Ricordiamo che con Excel possiamo stabilire, per ciascun prodotto, la quantità ottimale in termini di costi da ordinare per non superare la capacità massima di stoccaggio del magazzino.

=> Gestione ordini con Excel con magazzino limitato

Vogliamo anche avere un informazione riguardante per quanti giorni la quantità extra ordinata, consente di soddisfare la domanda. Inseriamo nella cella F8 la formula =ARROTONDA(((F7/C2)*365);).

Possiamo anche calcolare anche il Risparmio conseguito dall’aver effettuato questo ordine supplementare:esso è dato dalla differenza tra il nuovo costo unitario e il costo precedente, moltiplicato per la quantità Q: inserisco nella cella F9 la formula =(F2-C3)*F7.

La quantità di prodotto da ordinare come ultima occasione al prezzo di 16 € (cella C3, è calcolata nella cella F7 ed è pari a 3442 bottiglie. Questo consente di soddisfare la domanda per 105 giorni con una sola consegna e quindi di evitare (facendo il rapporto tra 105 giorni e i 13 col nuovo prezzo) 8 ordini con relativo risparmio in termini di consegne. Inoltre, il risparmio dovuto al soddisfacimento della domanda con bottiglie acquistate a 16 €, quando il prezzo è aumentato a 17,5 è valutato in 5163€.

I Video di PMI

PMI.it incontra Hevolus