Scadenziario Beni in Leasing con maxicanone iniziale con Excel – 2

Un prospetto per calcolare semplicemente il risconto attivo sui leasing in partita doppia

Costruire il modello

Analizziamo le procedure che permettono la creazione in automatico dello scadenziario dei beni in leasing; la lunghezza di quest’ultimo dipende dal numero delle rate previste contrattualmente alle quali deve essere aggiunta la data iniziale relativa al pagamento del maxicanone.

Nella cella A7 è stata utilizzata la formula:

=SE(O(B4=”";D3=”";F3=”";F4=”";D4=”");”";0)

La funzione SE consente di visualizzare nella cella il numero zero (0) solo se sono stati inseriti tutti i dati relativi al contratto di leasing nella parte superiore del prospetto (ad eccezione della cella B2 destinata ad accogliere la descrizione del bene preso in leasing); ciò consente di evitare la comparsa di messaggi di errori o la comparsa, nelle altre colonne dello scadenziario di numeri negativi.

Nella cella A8 è stata utilizzata la formula:

=SE(O($B$4=”";$D$3=”";$F$3=”";$F$4=”";$D$4=”");”";SE($F$3>A7;A7+1;”"))

La formula, composta da due funzioni SE nidificate, può essere letta in questo modo:

SE non sono stati inseriti i dati relativi al contratto RESTITUISCI una cella vuota, ALTRIMENTI SE il numero complessivo delle rate è maggiore del valore inserito nella cella A7, RESTITUISCI quest’ultimo valore aumentato di una unità ALTRIMENTI (ovvero, se abbiamo raggiunto il numero complessivo di rate) RESTITUISCI una cella vuota.

La formula è stata costruita con dei riferimenti assoluti in maniera da poter essere copiata verso il basso per trascinamento (tutte le formule della tabella che riporta lo scadenziario sono state inserite fino alla riga 47 del foglio di calcolo).

La colonna B del prospetto deve visualizzare le date delle scadenze periodiche dei singoli canoni leasing; queste ultime dipendono del tipo di rata (semestrale, quadrimestrale, etc.) indicata nella cella F6 e devono arrestarsi in corrispondenza dell’ultima rata riportata nella colonna A.

Nella cella B7 è stata utilizzata la formula:

=SE(A7=”";”";DATA(ANNO($B$4);MESE($B$4)+A7*12/$F$4;GIORNO($B$4)))

La funzione SE consente di visualizzare la data di scadenza delle singole rate solo se esiste un valore nella cella A7 e, pertanto, quando verrà trascinata nelle celle sottostanti, mostrerà delle date fino a quando esisterà un valore nella serie della colonna A.

Per visualizzare le date delle singole scadenze dei canoni leasing abbiamo utilizzato la funzione DATA e, come argomento di quest’ultima, le funzioni ANNO, MESE, GIORNO.

La funzione DATA è composta da tre argomenti (rispettivamente anno, mese e giorno) ed è particolarmente indicata nella realizzazione di serie di date in quanto permette di “traslare” automaticamente i valori dei mesi o dei giorni in eccesso: ad esempio, la funzione =DATA(2009;16;20) restituirà la data 20/04/2010 in quanto trasla i 4 mesi eccedenti (ai 12 che compongono un anno) sull’anno successivo.

Le funzioni ANNO, MESE e GIORNO, utilizzate come argomenti della funzione DATA, restituiscono rispettivamente l’anno il mese e il giorno di un numero seriale o di una data indicata come argomento; ad esempio, la funzione =ANNO(31/12/09) restituirà 2009, la funzione =MESE(31/12/09) restituirà 12 mentre la funzione =GIORNO(31/12/09) restituirà 31.

X
Se vuoi aggiornamenti su Scadenziario Beni in Leasing con maxicanone iniziale con Excel - 2

inserisci la tua e-mail nel box qui sotto:

Ho letto e acconsento l'informativa sulla privacy

Acconsento al trattamento di cui al punto 3 dell'informativa sulla privacy